User Tools

Site Tools


installation:gams_and_ubuntu_linux

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Next revision
Previous revision
installation:gams_and_ubuntu_linux [2007/10/17 16:57]
127.0.0.1 external edit
installation:gams_and_ubuntu_linux [2015/04/22 23:55] (current)
support
Line 1: Line 1:
-====== GAMS and Ubuntu Linux ======+====== ​Old GAMS and Ubuntu Linux (64bit)======
  
-There have been some issues with the installation of GAMS on Ubuntu Linux. ​It seems that the zip stuff is not compatible with ubuntuAlso csh was not available ​there. ​+There have been some issues with the installation of older GAMS distributions ​on Ubuntu Linux 64 bit (Linux ubuntu64 2.6.22-14-server). The main issue issue is that by default only 64bit programs will work there. ​
  
-  * leigams_sfx.exe ​did not run +Old GAMS installation scripts still relied on some 32bit programs (unzip) and thus did not work on a pure 64bit systemAlso some solvers were still 32 bit based and would not have worked either
-<​code>​ + 
-[ralm@ubuntu]:​ /​usr/​local/​gams$ ​./​leigams_sfx.exe +To install an old GAMS in such an environment,​ one would have needed to install the missing 32 bit libraries.  
-bash: ./​leigams_sfx.exe:​ No such file or directory + 
-[ralm@ubuntu]: /usr/local/gams$ file ./​leigams_sfx.exe +These are part of the Linux Standard Base (see http://www.linux-foundation.org/en/LSB) and can be installed simply by <​code>​ 
-./leigams_sfx.exeELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.0.0, dynamically linked (uses shared ​libs), for GNU/Linux 2.0.0, stripped+sudo apt-get install lsb-core 
 +sudo apt-get install ia32-libs 
 </​code>​ </​code>​
-but "unzip leigams_sfx.exe"​ ran OK.  + 
-  * no /bin/csh on the machine, so gamsunpack did not runAfter installing the tcsh package ​(it does not come as default in ubuntu, try: ''​sudo apt-get install tcsh''​) the problem was fixed.+If ''​gamsunpack''​ fails, you will also have to install ​the [[installation:​error_running_unpacking_script_._gamsunpack|tcsh package]]. 
 + 
 +With a current GAMS system, these steps should ​not be necessary anymore.
IMPRESSUM / LEGAL NOTICEPRIVACY POLICY installation/gams_and_ubuntu_linux.1192633027.txt.gz · Last modified: 2008/01/11 07:38 (external edit)